Audiobook Ingestion Notice [partners]
Incident Report for Findaway Voices
Resolved
This incident has been resolved.
Posted Jun 13, 2023 - 15:43 EDT
Monitoring
Ingestion of audiobooks at the following distribution partners is temporarily taking longer than expected. For the time being, please expect delays.

Audiobooks.com, Hoopla, Storytel, and Audible - ACX are experiencing delays
Posted Jan 07, 2022 - 10:17 EST